Tips & Guidelines

Focus on your experience using the product
Write your answer in clear English
Be polite - profanity won't be approved

Don't include personal info
Don't name other websites
Don't mention product prices

Answer Question

Scanner Compatability

Are there any scanners under £200 that are compatible with iMac OS X Yosemite Version 10.10.5 ? Some only work up to version 10.9

27/02/2017
David Ball
Existing Answers

David, The Canon CanoScan 9000F Mark II is compatible with Mac OS 10.6 - 10.12 If you have any issue using the drivers supplied with the scanner, the latest drivers are available for free download from the Canon.co.uk website.

01/03/2017
 
Your Details
Do you have a password?